PHP Fatal Error: Declaration must be compatible with (продолжение)

Ну, уж такого я вовсе не ожидал (хотя и был готов).

Та же ошибка в \Module::registerAutoloaders(), который, по мнению фалкона «must be compatible with \Phalcon\Mvc\ModuleDefinitionInterface::RegisterAutoloaders(\Phalcon\DiInterface $di=NULL)». Я даже согласен, но зачем это явно указывать, особенно с дефолтным значением? То есть, я в своем методе не могу оставить пустым список аргументов, хотя от него требуется только указание типа. То есть, я получаю сообщение об ошибке о неуказании типа отсутствующего аргумента. Вот глупости.

Таково требование интерфейса. Ладно, пусть я не прав.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *